Scheduling conflicts are the bane of the project manager’s existence. Scheduling conflicts typically fall into the following categories:

- Your project is taking longer than you had planned.
- Your resources are overassigned.

This chapter considers the first problem and focuses on identifying and then resolving scheduling problems; Chapter 10 focuses on the second problem.

Scheduling conflicts announce themselves in a number of ways. Changing views and filtering information by using the techniques that are described in Chapters 6 and 7 may identify some glaring problem that’s inherent in your original logic. For example, if you filter your project to view only incomplete tasks or slipping tasks, you may spot some problems. More likely, however, you’ll unknowingly create a problem by using a task constraint, which is explained in the next section.

Resolving Scheduling Conflicts

Project provides several techniques that you can use to resolve scheduling conflicts. This section covers the following strategies:

- Adding resources
- Using overtime
- Adding time
- Adjusting slack
Changing constraints
Adjusting dependencies
Splitting a task

As you work through the following sections, I suggest that you turn on Change Highlighting if you previously turned it off. Change Highlighting will help you identify the tasks affected by any changes you make as you work. To turn on Change Highlighting, point at the Change Highlighting button on the Standard toolbar or open the View menu. If the ScreenTip or the command reads “Show Change Highlighting,” click the tool or the command. If the ScreenTip or the command reads “Hide Change Highlighting,” do nothing, because Change Highlighting is turned on.

NEW FEATURE
Change Highlighting is a new feature in Project 2007.

Adding resources to tasks
Adding resources to a task can decrease the time that’s necessary to complete the task. On the Advanced tab of the Task Information dialog box (see Figure 9.1), set the task type to Fixed Units. In this instance, adding resources to the task reduces the duration of the task. Also, remember that a check mark appears by default in the Effort Driven check box of the Task Information dialog box. When you use the Effort Driven option, Project reallocates the work among the assigned resources.

FIGURE 9.1
The Advanced tab of the Task Information dialog box controls the task type and shows whether the task is effort driven.
Using overtime

In the best of all worlds, you have unlimited resources and you can add resources to resolve scheduling problems. After performing a reality check, though, you’ll discover that you don’t have unlimited resources, and adding resources may not be an option. But you may be able to use overtime to shorten a task’s duration, which is the next strategy that you can use to resolve scheduling problems.

For information on resolving resource conflicts, see Chapter 10.

Overtime in Project is defined as the amount of work that is scheduled beyond an assigned resource’s regular working hours. Overtime hours are charged at the resource’s overtime rate. Overtime work does not represent additional work on a task; instead, it represents the amount of time that’s spent on a task outside regular hours. For example, if you assign 30 hours of work and 12 hours of overtime, the total work is still 30 hours. Of the 30 hours, 18 hours are worked during the regular work schedule (and charged to the project at the regular rate), and 12 hours are worked during off hours (and charged to the project at an overtime rate). Therefore, you can use overtime to shorten the time that a resource takes to complete a task.

To enter overtime, follow these steps:

1. Display the Gantt Chart view (choose View ➢ Gantt Chart or use the View Bar).
2. Choose Window ➢ Split to reveal the Task Form in the bottom pane.
3. Click the Task Form to make it the active pane.
4. Choose Format ➢ Details ➢ Resource Work. Project adds the Ovt. Work column to the Task form (see Figure 9.2).
5. Move to the top pane, and select the task to which you want to assign overtime.
6. Move to the bottom pane and fill in the overtime amount for the appropriate resource.
7. Click OK. Project adjusts the schedule. If you have Change Highlighting enabled, the duration of affected tasks appears highlighted.

After you finish entering overtime, you can hide the Task form by choosing Window ➢ Remove Split.
Adding time to tasks

You can also solve scheduling conflicts by increasing the duration of a task. Again, in the best of all worlds, you have this luxury. In reality, you may not. But if you can increase the duration of a task, you may find that once-scarce resources are now available to complete the task — given the task’s new timing.

As you know, you can change the duration from several different views, such as the Task Usage view or the Gantt Chart view. You can also use the Task Information dialog box to complete this task (see Figure 9.3). To open the Task Information dialog box, double-click the task; then, use the Duration box to change the duration.
Adjusting slack

*Slack time* is the amount of time that a task can slip before it affects another task's dates or the finish date of the project. *Free slack* is the amount of time that a task can be delayed without delaying another task. Most projects contain *noncritical tasks with slack* — tasks that can start late without affecting the schedule. If you have slack in your schedule, you may be able to move tasks around to balance phases of the schedule that have no slack with phases that have too much slack. Therefore, you can use tasks with slack to compensate for tasks that take longer than planned or to help resolve overassignment of resources.

*NOTE* Slack values can also help you identify inconsistencies in the schedule. For example, you see a negative slack value when one task has a finish-to-start dependency with a second task, but the second task has a *Must Start On* constraint that is earlier than the end of the first task.

Almost by definition, you create slack time if you use the *Must Start On* constraint when you create your task. You set constraints on the Advanced tab of the Task Information dialog box (see Figure 9.4). To display the Task Information dialog box, double-click the task in your schedule. When the dialog box appears, select the Advanced tab.
Constraints can often create slack time.

To avoid creating slack time, use the As Soon As Possible constraint whenever possible. To find tasks with slack time, follow these steps:

1. Choose View → More Views to open the More Views dialog box.
2. Select Detail Gantt from the list and click Apply.

You can identify slack on the Gantt bars. Slack appears as thin lines that extend from the regular Gantt bars.

3. Right-click the Select All button and select Schedule from the list of tables.
4. Drag the divider bar to the right to view more of the table. Now you can see the Free Slack and Total Slack fields (see Figure 9.5).

Changing task constraints

Task constraints are the usual culprits when projects fall behind schedule. By default, Project uses the Planning Wizard to warn you when you are about to take an action that is likely to throw your project off schedule. For example, if you impose a Must Start On task constraint on a task with no slack time and with other tasks linked to it, Project displays the Planning Wizard dialog box (see Figure 9.6).
You can find slack time in tasks by using the Detail Gantt view and the Schedule table.

The Planning Wizard appears by default when you apply a constraint that is likely to lengthen your project schedule.
Similarly, if you impose an illogical start date on a task when recording actual dates, Project displays a Planning Wizard dialog box that resembles the one shown in Figure 9.7. For example, you see a Planning Wizard dialog box if you accidentally enter a start date for Task 2 that is earlier than Task 1, and Task 2 is linked to and succeeds Task 1.

**FIGURE 9.7**
The Planning Wizard also warns you if you try to record a start date that will cause a scheduling conflict.

Notice that you can turn off the Planning Wizard warnings by placing a check in the Don’t Tell Me About This Again check box at the bottom of the Planning Wizard dialog box. (Some people just don’t like to have wizards popping up all the time.)

If you turn off the Planning Wizard, Project still warns you if you take actions that cause scheduling problems. Instead of the Planning Wizard, Project displays a more traditional message (see Figure 9.8).

**FIGURE 9.8**
When you disable the Planning Wizard and take an action that may cause a scheduling problem, Project displays this warning message.
Project makes suggestions concerning actions that you can take to avoid these kinds of conflicts—suggestions that all refer to the predecessor task. Notice also that in contrast to the Planning Wizard, this message box does not give you the option of canceling your action.

So, although you may find the Planning Wizard annoying at some levels, it can actually save you effort at other levels. Sorry that you turned it off? To turn it on again, choose Tools ➤ Options and click the General tab (see Figure 9.9).

Select the Advice from Planning Wizard check box and then select the Advice About Errors check box. (You also can control the other types of advice that you receive in the same location.)

**Adjusting dependencies**

By changing task dependencies, you can tighten the schedule and eliminate scheduling conflicts. If you inadvertently link tasks that don't need to be linked, you may create a situation in which you don't have the resources to complete the tasks, and as a result, the project schedule falls behind. If you discover unnecessary links, you can remove them. When you remove the dependencies, you may find holes in the project schedule where work can be performed. After you remove unnecessary dependencies, you may be able to move tasks around and fill those holes.

**FIGURE 9.9**

You can control whether the Planning Wizard appears from the General tab in the Options dialog box.
You can use the Task Drivers pane (see Figure 9.10) to identify the task predecessor task that drives the timing of an individual task. Choose Project ▶ Task Drivers to display the pane. Then select a task. Project displays, in the Task Drivers pane, the predecessor task that drives the timing of the selected task.

The Task Drivers feature is new in Project 2007.

You can view dependencies graphically if you use the Relationship Diagram view in the bottom pane of the Gantt view (see Figure 9.11). The Relationship Diagram view shows you the selected task and its immediate predecessor and successor. Use the following steps to select the Relationship Diagram view:

1. Choose Window ▶ Split.
2. Click the bottom pane.
3. Choose View ▶ More Views.
4. Select Relationship Diagram from the More Views window and click Apply.
5. In the upper pane, click each task in your project to review its dependencies in the lower pane.

FIGURE 9.10
Use the Task Drivers pane to identify the predecessor task responsible for the timing of a selected task.
As you review the tasks, ask yourself the following questions:

- Do I really need to complete Task A before Task B begins?
- Can I perform the tasks concurrently?
- Can I do one of the tasks later without harming the project?

**Splitting a task**

Splitting a task can sometimes be the best way to resolve a scheduling conflict. You may not be able to complete the task on consecutive days, but you can start the task, stop work on it for a period of time, and then come back to the task. Project enables you to split a task anytime you determine that you need to make this type of adjustment. Remember that splitting a task creates a gap, which you see in the task's Gantt bar. Follow these steps to split a task:
1. Switch to the Gantt Chart view.

2. Click the Split Task button on the Standard toolbar. The button appears to be pressed, the mouse pointer changes shape, and a screen tip tells you how to split a task (see Figure 9.12).

3. Move the mouse pointer along the bar of the task that you want to split. As the mouse pointer moves, dates representing the split date appear in the screen tip.

4. Click when the screen tip shows the date on which you want to split the task; Project inserts a one-day split.

**TIP**

If you want the split to last longer than one day, drag to the right instead of clicking.

**FIGURE 9.12**

Use the Split Task button to divide a task.
After you split a task, it will look similar to Task 5 in Figure 9.13, with dotted lines appearing between the two portions of the split. If you decide that you want to remove a split, drag the inside portions of the split together so that they touch.

Using the Critical Path to Shorten a Project

Earlier in this chapter, you examined ways to resolve the scheduling conflicts that may develop. But what about simply shortening the time frame that you originally allotted for the entire project, thus becoming a hero? How would you accomplish that goal? You would evaluate — and try to shorten — the critical path.

The critical path shows the tasks in your project that must be completed on schedule in order for the entire project to finish on schedule — and these tasks are called critical tasks. Most tasks in a project have some slack, and you can delay them some without affecting the project finish date. However, if you delay critical tasks, you affect the project finish date. As you use the techniques described earlier in this chapter in the section “Resolving Scheduling Conflicts” to modify tasks to resolve scheduling problems, be aware that changes to critical tasks will affect your project finish date.

FIGURE 9.13

This Gantt Chart shows a split task.
Noncritical tasks can become critical if they slip too much. You can control how much slack that Project allows for a task before defining the task as a critical task. Choose Tools ➪ Options and then click the Calculation tab. Enter the number of slack days in the Tasks Are Critical If Slack Is Less Than or Equal To box at the bottom of the tab.

Identifying the critical path

You can see the critical path best if you use the Gantt Chart Wizard to display the critical path in red.

This discussion of the Gantt Chart Wizard focuses on displaying the critical path; see Chapter 8 for a more complete description of that wizard.

Open the View menu and select Gantt Chart. Then click the Gantt Chart Wizard button on the Formatting toolbar (the button at the right edge), or choose Format ➪ Gantt Chart Wizard. The first Gantt Chart Wizard dialog box welcomes you to the Gantt Chart Wizard. Click Next to move on to the next Gantt Chart Wizard dialog box (see Figure 9.14). Select Critical path to describe the kind of information that you want to display on the Gantt Chart.

Subsequent dialog boxes in the Gantt Chart Wizard enable you to select other types of information to display, such as resources or dates on Gantt bars and links between dependent tasks. These other choices that you can make while running the Gantt Chart Wizard are a matter of personal preference. When you finish, click the Format It button and then click the Exit Wizard button.

When you view the Gantt Chart, all tasks in the project still appear, but tasks on the critical path appear in red.

After you use the Gantt Chart Wizard, you can switch to any view and the critical tasks appear in red. Try the Network Diagram view, for example; the critical tasks appear in red boxes.
You can use formatting to identify critical tasks. When you apply formatting to critical and noncritical tasks, this formatting appears in all views in which you can see task bars. The formatting identifies critical tasks with a Yes in the bar of the tasks and noncritical tasks with a No.

To apply formatting, follow these steps:

1. Display the Gantt Chart view.
2. Choose Format ➪ Bar Styles; Project displays the Bar Styles dialog box.
3. Select Task from the list at the top of the Bar Styles dialog box to apply formatting to noncritical tasks.
4. Click the Text tab at the bottom of the dialog box.
5. Select a position for the formatting: Left, Right, Top, Bottom, or Inside. When you click a position, a list box arrow appears.
6. Click the list box arrow and scroll to select Critical (see Figure 9.15).

**FIGURE 9.15**
Use the Text tab of the Bar Styles dialog box to apply formatting that distinguishes critical from noncritical tasks.

7. Click OK.
After you apply the formatting, the Gantt Chart shows critical and noncritical tasks (see Figure 9.16). Because I placed critical information inside task bars, No appears inside noncritical tasks and Yes appears inside critical tasks.

Even with formatting, this approach to identifying the critical path can be cumbersome if your project contains many tasks. Alternatively, you can identify the critical path by filtering for it. As Chapter 7 explains, you can apply the Critical filter to any task view to display only critical tasks (see Figure 9.17). To apply the filter, display the view that you want to filter and choose Project ➤ Filtered for ➤ Critical or choose Critical from the Filter list box on the Formatting toolbar.

**FIGURE 9.16**
The formatting in this Gantt Chart identifies critical and noncritical tasks.
Filtering is an effective tool to display only certain aspects of the project, but sometimes you need to view all the tasks in your project and still identify the critical ones. If you use formatting (your own or the formatting that is supplied by the Gantt Chart Wizard), you can always identify critical and noncritical tasks — even if you are viewing all the tasks in your project.

**Shortening the critical path**

Shortening the time that is allotted on the critical path shortens your project's duration. The converse is also true: Lengthening the time that's allotted on the critical path lengthens the project. In all probability, you, as the project manager, are also responsible (at least to some extent) for the cost of a project. Typically, the longer a project goes on, the more it costs. Therefore, shortening the critical path is often the project manager's goal.

Shortening a project's duration can result in an earlier finish. But it also can mean starting later. Obviously, the second alternative is riskier, particularly if you are not confident in your estimates. If you are new to project management, you probably should not plan to start later; instead, use project management tools to help you evaluate the accuracy of your estimating skills. Over time
(and multiple projects), you'll know how accurate your estimates are and then you can take the risk of starting a project later than initially planned.

To reduce the time that is allotted on the critical path, you can do one or both of the following:

- Reduce the duration of critical tasks
- Overlap critical tasks to reduce the overall project duration

To reduce the duration of critical tasks, you can do any of the following:

- Reassess estimates and use a more optimistic task time. The PERT Analysis views can help you here.
- Add resources to a critical task. Remember, however, that the task must not be a fixed-duration task; adding resources to a fixed-duration task does not reduce the time needed to complete the task.
- Add overtime to a critical task.

To overlap critical tasks, you can do one or both of the following:

- Adjust dependencies and task date constraints
- Redefine a finish-to-start relationship to either a start-to-start or a finish-to-finish relationship

After you know the techniques that you can apply to adjust the critical path, you need to ask the important question: What's the best way to identify tasks that you want to change and then make the changes? The answer: Select a view, and filter it for critical tasks only. I prefer the Task Entry view, which is a combination view of the Gantt Chart and the Task Form view, because the top pane displays a graphic representation of the project and the bottom pane displays most of the fields that you may want to change (see Figure 9.18).

To set up this view, select the Gantt Chart view. The table that you apply to the Gantt Chart is a matter of personal preference; you may consider the Schedule table because it shows slack information. After you select the Gantt Chart view, choose Window ➤ Split. The Task Form appears in the bottom pane.

If you don’t see the Predecessor information in the Task Form, right-click the Task Form window and choose Resources & Predecessors from the menu that appears.

To filter for critical tasks, click in the Gantt Chart in the top pane of the view and choose Project ➤ Filtered for ➤ Critical. Click each critical task to evaluate it, and make changes in the Task Form in the bottom pane of the screen.

You also can sort your critical tasks by duration. That way, the critical tasks are in order from the longest to the shortest, and you can focus on trying to shorten longer tasks.
The Task Entry view, filtered for critical tasks, is probably the easiest view in which to work if you’re trying to adjust the critical path.

Using Multiple Critical Paths

Project enables you to view more than one critical path in a project. This feature comes in handy when you have lots of tasks that are driving other tasks and you want to find out which ones are truly critical to finishing the network of tasks on time.

By default, when you view only one critical path, you’re viewing the tasks that must be completed to finish the project on time. These tasks have no total slack. *(Total slack* is the amount of time that you can delay a task without delaying the completion of the project.)*

Suppose, however, that your project contains many subtasks, and within the subtasks you have dependencies. You may start wondering, within a given network of tasks, which ones are really critical. In this case, view your project with multiple critical paths, where Project displays a separate critical path for each network of tasks.
Consider the project that appears in Figure 9.19. In this figure, you see the following four networks of tasks:

- Network 1: Task IDs 2, 3, and 4
- Network 2: Task IDs 6 and 7
- Network 3: Task IDs 9 through 13
- Network 4: Task IDs 15 through 18

The critical path for the project appears with a cross-hatched pattern (on-screen, it’s also red) and revolves around the tasks in the first two networks.

When you display multiple critical paths, you see a critical path for each network of tasks (see Figure 9.20). For each unique task, Project sets its late finish date equal to its early finish date. When a task has no links, it is critical because its late finish is equal to its early finish. If a network of tasks contains slack, such as Network 3, some tasks are not critical whereas others are critical. When you view multiple critical paths, you can determine which tasks within a network of tasks must be completed on time to avoid delaying the network.
When you view multiple critical paths, you see the critical tasks within each network of tasks in your project.

By default, Project displays only one critical path, but you can change this default. Choose Tools \(\Rightarrow\) Options and click the Calculation tab to display the dialog box that appears in Figure 9.21. Select the Calculate Multiple Critical Paths check box and click OK.

Over time, the critical path of your project may change as tasks on the critical path are completed either ahead of schedule or behind schedule. If your schedule contains slack—the amount of time you can delay tasks before affecting other tasks or the project end date—you may be able to adjust your schedule to get it back on track. Use the Detail Gantt view with the Schedule table to help evaluate the slack in your schedule. On the Gantt Chart, slack appears as thin bars on the right side of task bars. In the Schedule table, you’ll find fields for Free Slack and Total Slack.
Summary

This chapter described the following techniques that you can use to resolve scheduling conflicts and shorten the length of your project:

- Adding resources to tasks
- Using overtime
- Adjusting slack
- Changing task constraints and dependencies
- Adjusting the length of the critical path

In Chapter 10, you find out how to resolve conflicts that occur with resources.